[Resolved] Pipe classes

Tagged: 

This topic contains 12 replies, has 2 voices, and was last updated by  SupportTeam 1 week, 1 day ago.

  • Author
    Posts
  • #2282177


    mikkaeg
    Participant

    Hi

    I’ve been using RP for a while now, but recently it has started to give me a lot of errors.
    I have created some new pipe classes , but now the app has erased them somehow.
    All the .csv and .xml files are still in the catalog folder, but the pipe classes do not appear in the configuration tool pipe classes list.
    At the moment, when I try to create a pipeline, there are no materials at all, not even the default ones.
    When I open the app, it gives an error, that the app is missing pipe classes, when trying to build curvature classes.
    I haven’t changed anything in the .xml files.

    Mikk

    • This topic was modified 1 day, 14 hours ago by  SupportTeam.
  • #2282178


    mikkaeg
    Participant

    Update.

    I have been looking into the issue.
    It seems that the Configuration tool cannot access the “pipe-classes.xml” file.
    When I try to open the file for the values of the pipe class, it automatically overwrites the “pipe-classes.xml” file.
    These are the contents of what is going to be left after the error:
    <?xml version=”1.0″ encoding=”us-ascii” standalone=”no”?>
    <pipe-classes>
    <attribute name=”lineic_mass” />
    </pipe-classes>

  • #2282179


    SupportTeam
    Keymaster

    Hi @mikkaeg,
    If you have a good backup of your pipe-classes.xml file you can just overwrite your current one.
    The configuration tool is still a Beta and we know it has some annoying bugs, we recommend to manually backup the catalog folder just in case, before using it.

    If you don’t have a backup, you can send me a download link of your directory “C:\ProgramData\Navinn\catalogs\pipe”, I’ll use it to fix your xml. (When posting you can check “Set as private reply” if you don’t want it to become public)

    Best regards

  • #2282180


    mikkaeg
    Participant

    Hi again

    I have a backup and I’ve already tried it- it doesn’t work.
    It recreates the xml files, but once I try to open the model, it cannot find the pipe classes.

  • #2282181


    mikkaeg
    Participant
    This reply has been marked as private.
  • #2282182


    SupportTeam
    Keymaster
    This reply has been marked as private.
    • #2282184


      mikkaeg
      Participant
      This reply has been marked as private.
      • #2282185


        SupportTeam
        Keymaster

        Hi, you link does has only the catalog.xml file and not a directory (I think you need to zip the directory before sending it)

        Also, as I said I don’t need your backup (Apparently it is not valid), but as said earlier the content of your current “Pipe” directory (“C:\ProgramData\Navinn\catalogs\pipe”). The configuration tool never delete a file from the folder, so if I have the folder content I can recreate an appropriate xml file.

        Best regards

      • #2282186


        mikkaeg
        Participant

        The problem is that I couldn’t stop my work, so I had to roll back my directory to the default settings (only the steel and stainless steel piping).
        If I could find out what was the problem with my created directory, then I could return to my needed piping classes.

      • #2282187


        SupportTeam
        Keymaster

        Hi, I’m trying to understand, what do you mean by roll back?
        Did you simply reinstall the standard catalog? Did you copy a backup from the catalog editor?

        Either way, your pipe class files (csv) should still be there, since both the installer and the Config tool don’t have the capability to remove files.
        You just have to add these csv files as references as mentioned earlier.

        If somehow you have manually removed these files, you still have two options:

        *You just open a rhino file where these pipe classes are used, and you will be offered to update the catalog automatically. The issue with this method is that it won’t use a csv file but register everything in the xml, loosing readability. And it will only import the DN used in the rhino file.

        *OR you re-create the csv files and associate them to the missing pipe classes. When you open the elbows file (“C:\ProgramData\Navinn\catalogs\elbow\elbow-classes.xml”) you can see that each elbow class refers to a pipe class. You just have to make sure that all these pipe classes exist.
        As I said, If you don’t manage to do it I can do it for you, but I will need a zip with your whole pipe directory (“C:\ProgramData\Navinn\catalogs\pipe”) and just the xml. And the elbow-classes.xml as well because I need to match the pipe classes names with this file.

        • This reply was modified 1 week, 2 days ago by  SupportTeam.
        • This reply was modified 1 week, 2 days ago by  SupportTeam.
      • #2282190


        mikkaeg
        Participant
        This reply has been marked as private.
      • #2282191


        SupportTeam
        Keymaster
        This reply has been marked as private.
  • #2282183


    SupportTeam
    Keymaster

    You can also have more detailled infos about manually editing the catalog here:
    http://forum.rhinopiping.com/tutorials/#CreatingPipeClass

You must be logged in to reply to this topic.